Windows 10 device descriptor request failed


#1

Hi,

I have a blinkstick square and when i plug it on W10, it says that the device descriptor request failed.

“Windows has stopped this device because it has reported problems. (Code 43)”

I tried to disable fast boot but it does nothing.

What can I do to make it work ?


#2

Hi Oliver and welcome to the forums,

have you already taken a look at this post:

Please let us know what else you have tried.


#3

I tried to branch the blinkstick using a hub and the windows error disappeared.
But now, when I go on “cmd” and try “blinkstick --info” or “blinkstick --pulse red”, it says that blinkstick is not a recognized internal command.
The blinkstick client does not start either.


#4

blinkstick --info can only work if you have the python package installed or the Blinkstick command line tool.
Please download the following zip, unzip it to a folder, run cmd and cd to this folder. Then try blinkstick --info again.

https://www.blinkstick.com/system/releases/windows/blinkstick-command-line.zip


#5

ok, i’ve reinstalled all the things needed and to pulse something, i need to python blinkstick --pulse instead of blinkstick --pulse only.
So, no usb error since i use now an usb hub (why do i need this ?? even at work i need the usb hub), and the blinkstick command seems to execute but nothing happens on the device.


#6

Hey Oliver,

It seems that there is a problem with some USB controllers, but mostly it is not neccessary.

Maybe the device is still in use by another instance. Maybe the python program is still connected to the device. You need to close all instances using BlinkStick before connecting it to another program.


#7

That’s what I thought. But the test I made was when I’ve just restarted the computer.
I restarted.
Plugged the device.
Launched the command on “cmd”.

Nothing.


#8

Can somebody help me ? The device does not work anywhere.


#9

@olivier_frantz did you try plugging it into a different computer?


#10

Yes, I tried at work. And it does not work either


#11

Did you forget me ? It’s been a while now.


#12

Just as a short reaction:
You´ve tested everything like usb hub, broken kabel, switching off usb power options in the window settings?
So always if you plugin the device in a windows PC you have an unrecognized device in the windows device manager?

I would like to send you a PM later to take care of your problem.


#13

I did everying’uou asked in this post and the other one you added as a reference.


#14

While looking for a solution, I´ve found another information.

Please take a look at this support page:
https://support.microsoft.com/en-us/kb/943104
The important part is the “Manually fix corrupted registry entries (Advanced Users)”.
Please read the instructions carefully.
The GUID in your case should be: 36FC9E60-C465-11CF-8056-444553540000

I also had a problem with the UpperFilters regarding the USB recognition in my VirtualBox. I hope it will help in this case also.


#15

Should i buy another one and hoping that you don’t something send me that does not works ? I want a refund or something. This is not acceptable.


#16

@olivier_frantz can you send me an email with your order number to info at blinkstick dot com and I will try to find a solution as soon as possible for you!


#17

I already done that months ago


#18

Device descriptor request failed error generally occurs when Windows isn’t able to read the connected device to the Computer. Maybe your ports are damaged, maybe device you’re trying to use is malfunctioned itself. Tere are many possible reasons behind this problem. There’s no need to take your laptop to the technician. You can solve this error on your own by following some tips given below.
If you’re getting device descriptor request failed error in Windows 10 or any other version of Windows, you should follow the steps:

  1. Restart your Windows computer device and try using the device again.
  2. Restore your Windows OS to previous restore points using Control Panel>Recovery>System Restore.
  3. Run system file checker scan.
  4. Update your drivers.