Blinkstick not recognized on win10

I have a blinkstick pro v1.0
When I plug into usb on device manager there is “Human Interface Devices”>“USB input Device” with an error “the device cannot start code10”
I have Dell laptop 5559 (i7) with win10 64bit
I tried connected to another laptop with win7 and I had the message “the device did not recognized…”
I also tried connect it through a usb hub
any ideas?

Hi Marios, welcome to the forums.
first off all please go through all the steps under this link (first post):

After this you can take a look at this microsoft support page:
https://support.microsoft.com/en-us/kb/943104
The important part is the “Manually fix corrupted registry entries (Advanced Users)”.
Please read the instructions carefully.
The GUID in your case should be: 36FC9E60-C465-11CF-8056-444553540000

Please let us know the results.

I tried different usb ports and again a usb hub but no luck
I tried also through manual edit the registry as it says here https://support.microsoft.com/en-us/kb/943104
I found the GUID but there is no entry “Upperfilters” or “Lowerfilters”.
Here is my registry:https://drive.google.com/open?id=0B-lMsxyfHiPAbnpYbVYyRzI1dkk

@mariosxenos do you have anything connected to BlinkStick Pro?

one smartpixel on “r” channel

Did you try connecting Pro without the smart pixel?

I disconnect the smartpixel. The same issue!
Is there any “inf” or driver file for blinkstick to force windows somehow to read form them?
Is it possible the chip has some problem or maybe my connections? In fact I have already double checked soldering and part positioning

or maybe is there any registry hack (a reg file ) to import directly to registry to be sure that windows read usb device in proper manner?

Inf drivers are already within the OS as BlinkStick is a standard HID device. Do you have a picture of how you connected the smart pixel to the pro?


the cut cables are because I disconnected the smart pixel to test without them

Are you sure you don´t have produced a short?
I would recommend to clean the flux from the board. Flux is not a conductor but could include rests of solder.
Just an idea.
The rest look ok to me.

I cleaned the board. No luck
When I plug the board into usb and if I had previously uninstalled the device, a dialog box opens saying that Blinkstick flex is installing.
When the installation ends the dialog box closes and nothing happens. In device manager again the Usb device not working.

I attach the installation process and the device properties hoping you can identify something interesting there. Thank you!


I tried with enabled/disabled touchpad (in settings) and with/without external wireless mouse

I´m sorry to say, but it seems like you broke your BlinkStick. “Extra end collection or no end collection” points to a wrong or broken firmware, also the fact that your BlinkStick Pro is recognized as a Flex. If you haven´t played around with another firmware a temporary short could be the reason…
Maybe you can try to flash the firmware…

In case the chip is damaged, is it possible to order a new one pre-programmed?

Drop me an email with your order number to info at blinkstick dot com and I’ll sort this out for you!

Thank you for your immediate and continuous support! I have already emailed you with my info. Please inform me for the procedure of ordering a new chip.

Thank you Arvydas and Blinkstick team for your help! My new Blinkstick works fine! It seems that somehow I damaged the chip during soldering and that was the reason for malfunction!

Thank you for your feedback!
Great to hear.
Now treat your BlinkStick well! :wink:

Good day!

I have the same problem as “mariosxenos”. My Blinkstick Pro is recognized under Win 7, win 10, Linux, and also does not have the raspberry PI. Same problematic as previously described. Suppose also that in my BlinkStick which chip is faulty. I would also like to receive a new chip. How can I get in touch with you!

MfG Sven