Unknown USB Device (Device Descriptor Request Failed)

Today I received my new blinkstick square including enclosure in the mail.

Eager to get going I installed the client software and plugged the device in. However the client couldn’t find the blinkstick and when I checked the device manager I found:

" Unkown USB Device (Device descriptor Request Failed)"

I tried all 6 usb ports on my pc, then tried another pc but no improvement. Then I also tried 3 different micro usb cables, but this didn’t help either…

Now I’m lost. Any idea’s on how to get going?

edit: Both pc’s are running Windows 10 x64

Hi Mike,

Sorry to hear you are having problems connecting your BlinkStick to your computer… Will try to get you sorted out as soon as possible :wink:

Are those USB2 or USB3 ports you are connecting BlinkStick to?

I tried both USB 2 and usb 3 ports on 1 machine, and the other only has usb 3 ports :weary:

Do you have a basic USB hub you could connect BlinkStick to? I’ve been looking into reasons why this is happening on some computers.

I do, an MS-Tech LU-204. Put it in between now but the computer still gives the Device descriptor request failed.

Are those laptop or desktop computers?

The one with usb 2 and 3 ports is a PC (Gigabyte main board) and the one with only usb 3 is a macbook pro with Bootcamp

Do you have the main board model number for the Gigabyte?

The Gigabyte is a GA-X58A-UD3R :slight_smile:

just tried another machine, giving the same error:

A gigabyte brix (GB-BXBT-1900)

I really think it is a broken device this time. But is kinda weird, I´m having not a single one out of 15 BS Square showing this behavior on every machine. If so it could be solved with a hub…
I have just one idea. If your hub is active try a passive one or if you have another hub close by try this.

I don’t have another hub unfortunately. I did a final test on another pc: Asus M5A97 R2.0 with windows 7 X64 on all USB 2.0 and USB 3.0 (giving the same result).

Even went to the store and got a new Micro usb cable that allows for data transfer but that did not help either :sweat:

Maybe you could try one more thing. Have a look at this link:


Look at Solution 5: Change the USB Selective Suspend Settings.

The selective suspend is the first thing i disable on installation of every machine I touch :wink: I checked if it was disabled though, and it is, so no progress there :frowning:

1 small thing that I do notice is that every time I plug it in one of the usb ports of one of the machines it gives a short blue blink and then goes off… I have no idea if this is normal behaviour?

The small blink is an indication that the device firmware is functioning correctly.

Thanks for letting me know. Will post you another one on Monday which hopefully won’t have this problem. Sorry about all the troubles.

1 Like

No problem, I hope the other one works so I can get coding :smile:

So far I didn’t receive any thing in the email, do you have any estimation on when it should arrive here? :smile:

Posted it on Monday as promised, so it should be with you any time next week!

It was in the mail today, and is working perfectly! :smile: