@arvydas Ime trying out the ruby examples but seems i cant install the ruby gem libusb as its no longer supported in the Ruby 1.9.3,ive also tryed the latest ruby wich will install the libusb gem but doesnt find blinkstick eather,so weather ime doing somthing wrong or its now broke and needs updating.any help with this would be great.
I´m using ruby 1.9.3 and I am able to install libusb without any problems. For me everything regarding blinkstick works fine with Ruby versions 1.9.3 and 2.2.6
@p0ke Hi,its saying libusb isnt supported in this version,ile try another.
@p0ke The error is > error installing libusb
ffi requires ruby version <2.5 , >=.2.0.
and bug segmentation fault.
wich version of 193 p ? do i install there a quite a few? thanks in advance @p0ke.
@p0ke 226 installs all fine now,but i get raise:error bellow.
Enter channel (R=0, G=1, B=2): 0
Enter number of LEDs: 2
raise_error': LIBUSB::ERROR_INVALID_PARAM in libusb_submit_transfer ( LIBUSB::ERROR_INVALID_PARAM) from C:/Ruby22/lib/ruby/gems/2.2.0/gems/libusb-0.6.2-x86-mingw32/lib/lib usb/transfer.rb:202:insubmit!’
submit_and_wait' from C:/Ruby22/lib/ruby/gems/2.2.0/gems/libusb-0.6.2-x86-mingw32/lib/lib usb/dev_handle.rb:544:insubmit_transfer’
control_transfer' from C:/Users/Dunk/Desktop/blinkstick-ruby-master/blinkstick.rb:64:ins
from example-pro-run.rb:44:in `’
It is a bit tricky to get it to work under windows.
For your problem take a look at the solution here: