Only 8 LED are on (Blinkstick Flex)


#1

Hi,

i buy some of the BlinkStick Flex and plug it into my PC. After Download and install BlinkStick 2.0 it doesn’t work . Only the first 8 Leds (0-7) are on. What do i Wrong ???


#2

Did you change the mode of the device?


#3

Where can i check this ?


#4

Hi i have same problem,it only uses the first 8 leds,and mode wont change from all leds.ive tryed python to change mode,it still doesnt work,i bought it cause ive a led strip of 30 addressable leds,and thought it would run them all,my pro does no problem.


#5

Its allmost like it has the wrong firmware on,like blinkstick strip?


#6

sry i’m from germany an don’t understand it what you mean :frowning:


#7

Hi,dont worry about it @arvydas will fix it,he is just verry busy,i think he is sorting somthing to fix the issue,i told him about mine a couple of weeks ago.


#8

Well I’m sure he’s trying to help but if you want him to help you, you need to help him by answering the questions he asks.

I think you need to set it to mode 2 for the flex, but I’m not sure about that. There’s also this thing called mirror mode, which is mode 3, that sounds like it only works with 8 LEDs. I think you might have accidentally set mode 3. To set it to mode 2, run this command from a terminal.


#9

Hey Karsten,

I´ll try to give advice in german by PM. Please see your PM and let me know if you need any more help.


#10

Hi mine is in mode 2 that’s the only mode my flex works in,can’t change it in client,or by any other means,or it crashes,the 32 LEDs flash etc on the client app,I can do what I want on the client LEDs,but my LEDs on the flex don’t,only the first 8,I’ve managed to get the firmware hex from my flex it maybe worth checking its not strip firmware with flex eeprom serial,details @arvydas let me know if you want me to send it to you just to make double sure the firmware is right.


#11

Hey dunk,

please download this little ZIP:
https://dl.dropboxusercontent.com/u/19452479/BSTest.zip
Unzip it to any folder. Plug your flex in and then start this tool.

It should show “BlinkStickFlex” the serial and the Mode. If so, do a right click in the properties and select “SetColors”. Tell me what happens (hopefully the flex light up all LEDs) and what mode is shown in the properties.

It is only a unstable test tool, so don´t expect any comfortable thing :slight_smile:

Edit: Just updated the tool. Now you can see the LEDCount. If you have only 8 there, you can set it to 32 over the context menu.


How to morph colors on the flex
#12

Holly Sh*t it works,

i use the tool an configurate it from 8 to 16 an close it. Than i open the firmeware and now i can controll 16 leds


#13

Thanks @p0ke thats done the trick,they all come on now multi colored,so my flex is normal then?


#14

Good! A note to @arvydas: It seems you send some devices out with a default setting of 8 LEDs. I´ve build a small tool using your last API to set the flex to 32 LEDs.

@dunkyoung25: If you start the tool again and it shows 32 LEDs then your flex seem to be ok :smile:


#15

Well when i start the tool again i have to click on set colors again.


#16

SetColors only send the colors as package to the device. The most important thing is, if the tools shows 32 LEDs for the devices at startup. If so you should be able to use BlinkStick Client as usual.


#17

Aww i see,well cliant still only 8 leds


#18

Weird, user Karsten told me it worked for him :disappointed:


#19

Aww just started working now,i restarted client,thanks verry much p0ke :stuck_out_tongue:


#20

@p0ke does your client have crosses in the three boxes at the top,mine has lost the bin etc too xamarin installation seemed to have messed my client up.