Can't get Windows to recognise the BlinkStick


Hi, I’ve just received my Blinkstick Nano (thanks) but I’m having troubles getting started. I installed the BlinkStick_Setup_1.0.1.exe and restarted my system (Win7 Pro, x64), but every time I plug in the BlinkStick itself, Windows pops up with “USB Device not recognised. One of the USB devices attached to this computer has malfunctioned and Windows does not recognise it” - it sometimes then proceeds to a driver install screen, but then pops up with 'Device Driver software was not successfully installed" - I’ve tried running the BlinkStick Client, but going to BlinkStick->Test (Or manage) shows 0 devices listed. I’ve tried the Blinkstick in all 6 USB ports on the PC but I get the same results on each one. Not really sure what I’ve missed, is there a driver I was supposed to install? (I’ve since tried a few restarts, with/without the BlinkStick inserted but with the same results)


Hey Steve,

welcome to the forums!

Do you have a USB hub close by? Could you please try to get it to work over a hub?
Also keep sure that it is no USB 3.0 port where you connect your BlinkStick.

If possible try your BS on another machine.


Thanks for the quick reply. I don’t have a hub to hand, but I’ll try another machine (and/or a USB hub) this evening and report back…


I tried it on the server it’s intended for (Windows Server 2012, in a USB 2.0 port) but it had the same result (USB device malfunctioned) - I then tried it on my laptop (running Win10) and it sprang into life. So it seems like the BS is functioning fine, but not on the machine I bought it for (the server, I run it headless and the indicator light will be massively useful to me, I’ve already used the API and built it into my existing software, so I’m itching to get it working now!).
Will a USB hub cure the issue? (For that matter, what is the issue?)
Typically I can’t find a hub to hand, so I’ll either rummage around or grab a cheap one if it definitely fixes the issue!


Hey Steve,

just a few ideas:

  • Check the power management of the root hubs in the device management. If you give windows the control over it, it could cause problems with HID devices.
  • In my case a BS works behind an additional hub, but it does not if connected directly to the board. I cannot promise it it is always the cure but in my case it was.
  • We had problems with USB devices on a server OS because of a special USB blocking tool. Could that be an issue in your case?
  • The “malfunctioned” issue is not just an issue with BS. It could happen to printers, keyboards etc. Then it could be the general USB port driver or a problem that the onboard USB ports don´t deliver enough voltage (had this issue with an ASUS board).

It is just a bunch of ideas, so don´t be disappointed if none of these lead to a solution. :wink:


Hi p0ke, was your USB hub a powered one, or was it just bus powered?
(I tried disabling the Windows power management of the root hubs, but it didn’t work :confused: )
Thanks for the ideas,


It is interesting but in my first case (private win 10 pc) it is a passive hub. In my company we´re using active monitor hubs for win 7 PCs.


I’ve ordered a decent (powered) USB 2.0 hub, hopefully that allows it to work on my server.
p0ke, did you find that some models of BS were more reliable than others? (i.e. is there one particular type that works on any of your computers without a hub?)
I’m surprised that this isn’t more of a widespread problem with the BlinkStick though, I’ve now tried it on 6 different machines and it only works on one of them (Three Win7 Pro, one Win8.1, one Win10 and a WinServ2012) - the only one it works on is my Win10 laptop. I can’t believe that I’m that unlucky, surely many people must also get this fault? Is it possible my BS is faulty? (I can’t explain why it works on one machine though)
The other five machines all display the exact same error when it’s plugged in (malfunctioned) - I tried the MS FiXit ( but it didn’t work either.

I’m gutted this doesn’t work reliably on different machines, I was going to build an app to monitor some servers at work (write to SQL and have a local agent controlling LED) and display the status of various servers on a strip stuck to my computer, but I’m dubious that it’s going to work (if I order a BlinkStick strip)


Hey Steve,

I have 10 permanent attached BlinkStick Square devices in our company. 3 of them (1 Win 10, 2 Win7) connected to the PC directly, the rest (Win7) is attached to a monitor hub.
On my private PC I work only with a passive hub at the moment. Devices that work are: 3 BS Square, A Flex, a Nano, a Strip and a few BS Pro devices. The OS is win 10.

I could give it a try to attach it to a direct USB port again, will take care of it this evening or tomorrow.

Maybe @arvydas will meanwhile give a statement to this. Possibly the device really does not work as it should.


@Steve can you try plugging the BlinkStick through a USB extension cable. No need for a hub. I might suspect that the USB contacts on the board are not touching the pins in the USB socket of other computers that may prevent BlinkStick from communicating with PC. If you want to try a USB hub, then it does not have to be powered.


I’ve just tried 2 different USB extension cables but it has the exact same issues (malfunction error)
I tried some different ports too.
For the sake of completeness I also tested the extension cables in my [known-to-work] laptop and it all functioned fine. The hub will arrive tomorrow, so fingers crossed it works with that…


Ok, I had the chance now to reproduce this.
All USB 2.0 ports are behind my PC so I never tested without the hub on my desk at home.
My private PC board is a GIGABYTE Z77N WIFI. OS is Win10.
Everything works fine with my passive USB hub. But directly connected neither the Nano nor the Square can be recoginzed! I get the same malfunctioned message like Steve reported. I´ve tried 2 different extension cables which work correctly for my USB stick.
btw: I´ve tested the hub and the direct connection to the same USB port also. hub works, directly no way!

So @arvydas it really seems that we have an issue here, but it also seems, @Steve, that you can solve it with your ordered hub.


Used a hub (without power) - and bang - started working immediately!
So there’s a strange issue there somewhere.

In case anyone needs one, I’ve seen a really cheap [passive] hub for £1.35 (delivered(!)) - - I’ve ordered one for the server so I’ll report back if it works.


Interestingly the eBay hub doesn’t work with the Blinkstick (I get the same device malfunctioned error when connecting via the hub) - when plugging other devices into the hub I get ‘this device can perform faster…’ pop-up, so it seems the hub is only 1.1. (Which partially explains why it’s so cheap)
I now have a BlinkStick strip [for a project at work] so I’ve had to order a better quality hub to go with it - (it has the same ‘malfunction’ issue when plugged directly into most USB ports)


Hey Steve,

thanks for your feedback. USB 1.1 should be ok!

@arvydas: I´ve tried to sort this out a bit… Win10 changed the USB architecture. Maybe the issues with BS here are a mix of OS Win10 and the hardware. The following link includes all the steps i´ve already tried to get BS work directly at the USB port:

No luck with any of the steps :-/

Note: I have no problem at the moment. Win 7 works fine and also Win 10 when operating behind a hub (in my case!). But my opinion is we have a general issue here. What do you think?


Just for the record, my Windows 10 laptop works fine with the BS without a hub, so I don’t think the OS is to blame.


Just to follow up - the AmazonBasics hub works a treat:

(£5.49 delivered)


Just got my Nano, and just reporting on a Dell desktop Optiplex 9020 I had the same issue. Used a front USB port (not USB 3.0) and it didn’t recognize it. Then tried the USB 3.0 port and still no joy. Then as this thread suggested (and thanks because I wouldn’t have thought of this) used an old Belkin powered hub I had laying around and it worked.


I had the same issue (USB device malfunctioned…) while trying to connect a new and fresh BlinkStick Pro with all 3 available USB 2.0 Ports at my ASUS laptop … over and over again - with no success.

Checking the device manager and using a USB diagnostic tool i got the information, that my USB mouse needs (takes) 98mA, but i could’nt see the still plugged BlinkStick Pro. All other ports have been reported to offer 500mA each - by device manager and diagnostic tools…

Last idea was to UNplug ALL usb devices and plug in the BlinkStick ALONE - and tada - BlinkStick was found and gets recognised from windows and from within the client-software like a charm, even after the mouse has plugged in again ^^)

The device manager does report 40mA needed by the BlinkStick while NO LEDs are connected by now. I try to max the consumtion by connecting 8 x WS2812 and keep you updated about the final results.

Maybe someone struggles with the stick itself after soldering the device and can get it to work through unplugging all usb devices and using the BlinkStik alone for once too!?

GL & HF!