Blinkstick Pro "Factory" Reset


#1

Hello,

I am new here and this is my very first “do it yourself” project, therefore I might have rather dumb questions.

I think I messed up my Blinkstick pro, I tried the search to see if I can reset the blinkstick pro somehow but I didn’t find anything.

Longer Story:
I build the blickstick pro myself, windows can find it so does the blinkstick client 1 and 2 as well as BSAL.
I attached my individual addressable LED strip (27 LEDs) for testing.
After some back an forth the first LED turned on, but the colors are wrong, when I select red in the software the LED actually shows green.
I tried the ambilight software BSAL, it works, but the same issue, colors are wrong.
In blinkstick client 2 I selected “multi-LED” as mode, the others only show white LEDs, but that’s normal due to the type of LED strip I use.

So how did I mess up my blinkstick?
I tried to resolve the color mismatch, so I figured, blinkstick client 2 is beta, lets try client 1.
Client one found the blinkstick pro, but did not offer “multi-LED” mode, only normal and inverse.
So I selected a few things, just like an idiot, clicked on everything to see what happens.
The serial number in client 1 was shown as some weird icons instead of the actual number like client 2 did.
So I deleted client 1 and went back to client 2, however the blinkstick pro is now stuck on “inverse” mode, when I go to the blinkstick pro settings, I can change the name, that will save, but when I select a different mode, save and then go back to the settings, it’s back on inverse.

Therefore, how do I completely reset my blinkstick pro?
And as a bonus, any idea why my colors are wrong and what I can do to change it?

PS: also client 2 is currently showing the weird serial number format. original in black box, new weird one in red box.
0-rc10


#2

Take a look at this post:


#3

Thanks, so I installed all the things however I have the same issue as the last post, the make commands won’t work. I have not the slightest idea of programming, so I am kinda lost.

cmd spits out this:
=========================
C:\Users\myuser\Downloads\blinkstick-firmware-pro> make clean hex
rm -f main.hex main.lst main.obj main.cof main.list main.map main.eep.hex main.elf
process_begin: CreateProcess(NULL, rm -f main.hex main.lst main.obj main.cof main.list main.map main.eep.hex main.elf, ...) failed.
make (e=2): The system cannot find the file specified.
make: *** [clean] Error 2
=========================

I downloaded the pro firmware, copied the eeprom.hex from the normal firmware.
I renamed the rom and serial files as per your manual. see picture.

2018-11-12%2017_01_56-blinkstick-firmware-pro


#4

Ok so I made it a bit further, but I am stuck again. :confused:

“make clean hex” worked, however make default does not.
first make default used usbtiny, I copied the command and changed it to avrisp.

avr-gcc -Wall -Os -DF_CPU=16500000 -Iusbdrv -I. -DDEBUG_LEVEL=0 -mmcu=attiny85 -o main.elf usbdrv/usbdrv.o usbdrv/usbdrvasm.o usbdrv/oddebug.o light_ws2812.o main.o
rm -f main.hex main.eep.hex
avr-objcopy -j .text -j .data -O ihex main.elf main.hex
avr-size main.hex
   text    data     bss     dec     hex filename
      0    4176       0    4176    1050 main.hex

myPC MINGW64 ~/Downloads/blinkstick-firmware-pro
$ make defaults
avrdude -c usbtiny -P usb -p attiny85  -B 3 -U eeprom:w:eeprom.hex:i
avrdude: Error: Could not find USBtiny device (0x1781/0xc9f)

avrdude done.  Thank you.

make: *** [defaults] Error 1

myPC MINGW64 ~/Downloads/blinkstick-firmware-pro
$ ^C

myPC MINGW64 ~/Downloads/blinkstick-firmware-pro
$ avrdude -c avrisp -P usb -p attiny85  -B 3 -U eeprom:w:eeprom.hex:i
avrdude.exe: ser_open(): can't open device "usb": The system cannot find the file specified.


avrdude.exe done.  Thank you.


myPC MINGW64 ~/Downloads/blinkstick-firmware-pro
$

#5

What kind of programmer u are using?


#6

uhm… not sure what you mean, I use Git Bash as shell and the BlinkStick Pro is plugged in to USB. The stick shows up in windows, so its recognized by the system.


#7

U can’t flash firmware over USB. You need some kind of AVR programmer connected directly to the attiny chip.


#8

Hey, thanks for your help so far.

I have a programmer now, however I guess I bought a shitty one.
I purchased a variant of the CH341A programmer.
Sadly this programmer is not supported by avrdude, and the software that works with the programmer does not work with the ATtiny85 chips. I’m lost again. :confused:

I did find this: https://github.com/flashrom/flashrom/blob/staging/ch341a_spi.c
But apparently I am to stupid to make it work.

Do you know the CH341A and can help, or at least suggest a proper programmer I could buy?

Thanks


#9

An AVR programmer like USBTinyISP from Adafruit will work or just use an Arduino as programmer.

https://www.arduino.cc/en/Tutorial/ArduinoISP