BlinkStick Client Crahes with Many Error Windows


Just received my BlinkStick Flex today and was really excited to try it out. I first installed client version 2 RC 9 but the application crashes with many error windows. See screenshot here: I checked the log files but they are all empty! I then uninstalled v2 and installed v1. Client v1 does recognize the device, but changing colors and such doesn’t do anything. I have tried reinstalling both versions but the same problems still persist.

I have a HP Omen laptop (with only USB3 ports) running Windows 10.

Any help would be appreciated!

Forgot to mention above, but I tried all the USB ports but none worked

Hello Kevdliu and welcome to the forums,

first of all we should try if the BlinkStick works generally. Could you please download the following zip and unzip it to one folder:
Start the tool BlinkStickTestTool.exe and see if the device is recognized and if you can change the colors.

Please let me know your results.

Hi p0ke thanks for the reply. I ran the test tool and it did recognize my flex. It shows LEDs to be 32 and mode to be 2. When I set the CurrentColor however, only the first LED changes color. Is that expected behavior?

Interestingly, the python BlinkPulse music visualizer works perfectly (BlinkStick Visualization Showcase)

the good news is that your device works as expected. The behavior you´ve described for the small test tool is normal.

So the problem ist somewhere in the BS Client software. All you can try is to uninstall it again and delete every folder manually (also the %HOMEPATH%\AppData\Roaming\Agile Innovative\BlinkStick\ ).
Then try to reinstall the last version (2 RC9) again.
Otherwise we have to wait for an advice from @arvydas

I had the same problem (2.0 RC10). Can be fixed as explained earlier with the uninstall and cleaning of the folder.

However every time this problem occurs you would need to do the procedure again.

I just recently got my Blinkstick Nano and had this problem twice during the first 5 min of use. I would not call this the best out-of-the-box experience… :expressionless:

How are you addressing the LEDs? This error is very easy to trigger if you address an LED that’s out of the index range. For a 32 LED Flex, the first LED will be 0 and the last will be 31.

To give an example, using V2 of the software on Windows 10:

I cut 11 LEDs off the end of my Flex so currently it only has 21 LEDs. This is how I have it set up


Thanks for the tip of the LED array - that solved my problem!!! I had 0 to 8 - but there are only 8 (not 9) IDs!