BlinkStick 2.0-rc10 Remote Control will only work on localhost

I’ve installed BlickStick 2.0-rc10 on Windows 10 and enabled the remote control. I can control it easily enough via, but if I try using the IP address of my machine,, I just get an ERR_CONNECTION_REFUSED error in Chrome

Thinking there was an interface clash (I’ve got Docker NAT and two WiFi cards installed), I disabled everything so the only interface left was the WiFi card with the above address and restarted BlinkStick, but I still get that error.

Windows Firewall is switched off, I’ve got no AV products installed, I’ve changed ports to something I know is free. I’ve got nothing else that could possibly stop this from running.

Any clues?

You need to specify “Bind Address” to be in order for this to work. Just edit the remote control notification and you will find the setting there.

OK, already 4 years later. But things as tailscale, ngrok, Nebula and ZeroTier have come in use.
In the case of Tailscale, they create a “private network” in the range.
An “adapter” appears so on the host for that private IP.
But setting that private 100...* IP in BlinkStick 2.0-rc10 “remote control” does not seems to work (even with windows firewall off for test)
But things as windows “Remote Destop Connection” works, as on linux local services.
So did someone find a way to make “Remote Control” work with such private networks as TailScale.
If this could work it can open up lots of possibilities for using the “remote control” for monitoring, etc…

Hi, I’m on Windows and I have the same problem. Remote control works in localhost but not elsewhere in the local network. I tried changing the bind address and requests just fail.

Has anyone found a solution for this?