BlinkStick 2.0-rc10 Remote Control will only work on localhost


#1

I’ve installed BlickStick 2.0-rc10 on Windows 10 and enabled the remote control. I can control it easily enough via http://127.0.0.1:9000/api/v1/set_color/BS012345-3.0?color=red, but if I try using the IP address of my machine, http://192.168.1.2:9000/api/v1/set_color/BS012345-3.0?color=red, I just get an ERR_CONNECTION_REFUSED error in Chrome

Thinking there was an interface clash (I’ve got Docker NAT and two WiFi cards installed), I disabled everything so the only interface left was the WiFi card with the above address and restarted BlinkStick, but I still get that error.

Windows Firewall is switched off, I’ve got no AV products installed, I’ve changed ports to something I know is free. I’ve got nothing else that could possibly stop this from running.

Any clues?


#2

You need to specify “Bind Address” to be 192.168.1.2 in order for this to work. Just edit the remote control notification and you will find the setting there.