Blinkstick Square not working

I got my BlinkStick Square in the mail a while back, but it’s not working.

blinkstick --info doesn’t return anything, and it doesn’t show up when I run ioreg -p IOUSB either.

I’ve tried different USB cables, and it does blink some of the LEDs just as I connect it.

Is it possible to get it replaced?

Sorry to hear you are having trouble with your BlinkStick. Can you see the LED briefly flash when you plug it in?

Yes it does, but after that I get nothing

@arvydas Do you have any troubleshooting tricks I can try, and if not, is it possible to get a replacement?

That blinkstick --info is a linux command ?
I am fairy familiar with linux and I was unable to setup the software for it.
I would try the windows software because it is easy to click and test the leds.

blinkstick is a python cli that I installed calling sudo pip install blinkstick.

I don’t have a Windows machine but I can try to see if I can run the Windows client in a VirtualBox instance, but I’m not sure how well that plays with USB peripherals.

I tried running the Windows client through VirtualBox today @adriantnt , but that didn’t work either. (see screenshot)

Any more ideas @arvydas? Do you have a return policy?

That appears to be the old software, if you still want to test, try this, it should work fine:

Please also make sure that your cable allows to transfer data together with power supply.

If you will be able to transfer data from your phone, you will be also able to use stick

Yes, tested a bunch of different USB cables and finally it worked. An old Kindle cable did the trick

1 Like