Blinkstick client 2.0 and/or cpu usage


#1

So, i’ve bought my first Blinkstick Pro, with adapter, the whole lot works great and for this I thank you dearly!
But my problem at this stage is: If I Install the latest client, i cannot get AmbiLight to work, but if I install the 1.0.3 client (which works with AmbiLight), I get rather high CPU usage (being 20%) this is not a huge problem for general pc usage, although i do like myself some nice games every once in a while, and these may require my full processor.

Now my question is: Can i fix the CPU problem, or could i fix the 2.0 client problem? if either are possible please respond.
Thanks in advance,

Regards,
Arno De Keersmaeker


#2

Hey Arno and welcome to the forums.
Please let us know how excactly you´ve configured your CPU notification in the BlinkStick Client.

Everythink works fine for me (Ambilight & CPU usage) with BlinkStick Client 2.0 on a Windows 10 and Windows 7 machine.


#3

Well, i first launched the client, and went to manage, and set my strips to inverted.
After this I added a notification for AmbiLight and one for no light. No further problems or in depth stuff to tell i think.

However, you might’ve misunderstood me when i said cpu usage, this is not a notification i set up. my remark is that the cpu usage of the client application is taking about 20% of my total cpu, and this may cause some latency on certain apps. the question still being: should i fix the cpu problem or take a new version of the client.

Thanks for the assistance!


#4

Hey Arno,
sorry for misunderstanding.
The high ambilight CPU usage in older versions is a known problem. It has been fixed in the 2.0. So taking the newest version of the client should be the right way.


#5

I thought it would indeed fix this problem but my problem is that ambilight notification does not work on the latest version of the client.


#6

Tested it again 5 mins ago. Win10 and BSClient 2.0 rc9. Ambilight is working well.
Please post the ambilight node at %HOMEPATH%\AppData\Roaming\Agile Innovative\BlinkStick\data.json.
You could also check %HOMEPATH%\AppData\Roaming\Agile Innovative\BlinkStick\logs for any ambilight log.


#7

with post the ambilight node do you mean:

“Notifications”: [
{
"$id": “56”,
"$type": “BlinkStickClient.DataModel.NotificationAmbilight, BlinkStickClient.Base”,
“Enabled”: true,
“Name”: “Ambilight1”,
“BlinkStickSerial”: “BS007943-2.2”,
“LedFirstIndex”: 1,
“LedLastIndex”: 63,
“LedChannel”: 0

Also, the logs found in the %HOMEPATH%\AppData\Roaming\Agile Innovative\BlinkStick\logs location are either blank notes or start with BlinkStick Client 1.0.3 application started.

Whence I launch the new client’s Ambilight notification the whole client crashes (get’s stuck and says ‘stopped working’), if i disable it i can continue to use the client, if still enabled i can do anything except for edit, activate or delete Ambilight. very strange indeed


#8

Hey Arno,
please change your LedFirstIndex and LedLastIndex to 0.
This should fix the problem. When I´m right you´re using the BS Led Adapter with a simple LED strip. In this case you don´t need to set the LED index. Afaik there is a known issue with the LEDIndex.

I hope it helps.

Edit: Just as information: For let the BSClient giving more information in the log you have to set “LogLevel”: “Full”, in %HOMEPATH%\AppData\Roaming\Agile Innovative\BlinkStick\settings.json


#9

Alright so i just tested both, setting the leds to 0 and changing the log information.
As far as the client goes, still the same, no response from ambilight, still crashes whenever i try activating or de-activating.

Now, the logging supposedly works fine and the last log i received of my AmbiLight is:

2017-01-21 18:38:05,424 [1] INFO Main - --------------------------------------
2017-01-21 18:38:05,429 [1] INFO Main - BlinkStick Client 2.0-rc9 application started
2017-01-21 18:38:05,431 [1] INFO Main - Found GTK# version 2.12.30
2017-01-21 18:38:05,522 [1] INFO Main - Loading data
2017-01-21 18:38:05,556 [1] DEBUG Main - Registering/Unregistering startup
2017-01-21 18:38:05,557 [1] DEBUG Main - Loading main form icon
2017-01-21 18:38:05,661 [1] DEBUG Main - Building popup menu
2017-01-21 18:38:05,663 [1] DEBUG Main - Showing popup menu
2017-01-21 18:38:05,663 [1] DEBUG Main - Setting up tray icon
2017-01-21 18:38:05,782 [1] DEBUG Main - Setting up treeview
2017-01-21 18:38:05,786 [1] DEBUG Main - Adding notifications to the tree
2017-01-21 18:38:05,837 [1] DEBUG NotificationService - Creating service…
2017-01-21 18:38:05,837 [1] INFO NotificationService - Service created
2017-01-21 18:38:05,838 [1] INFO NotificationService - Starting notification monitoring…
2017-01-21 18:38:05,838 [1] INFO NotificationService - Started.
2017-01-21 18:38:05,838 [1] DEBUG Main - Initialization done
2017-01-21 18:38:08,704 [1] DEBUG NotificationService - Notification Ambilight:Ambilight1 starting
2017-01-21 18:38:08,704 [1] INFO Ambilight:Ambilight1 - Starting Ambilight
2017-01-21 18:38:08,731 [1] DEBUG Ambilight:Ambilight1 - Ambilight started

So according to this log it should work, but nothing responds, i set the colour to green (so i see a big difference if it does work) restart the client, to make sure it all starts off well, it launches and when i then test it, nothing changes, and when i disable it it still crashes so i see no significant difference so far.


#10

Sorry, I´ve absolutely no idea at the moment.
You could try to delete your data.json, Then start BSClient and add a notification for ambilight again. Change nothing in the presettings but the device you need.

Hope @arvydas has another hint…


#11

It’s alright, it still works, just a bit less optimised then it could.
For now I will patiently wait for the next version, do you by any chance have a lead on when i might be able to see a new version of the client?

Otherwise i too, hope that Arvy might have an idea, otherwise I’ll stick to what i have, i have tried multiple CPU stress’ and if i set the client to low priority it does not seem to interfere or block the performance outcome too much, in other words: the 1.0.3 client isn’t too bad, just a shame I can’t yet use the newer client.

P.S.: I did find a temporary fix called ‘prio’ which can set your task priority to low even after a restart. This seems to work pretty well.